this post was submitted on 31 Jul 2023
47 points (96.1% liked)

Programming

17025 readers
227 users here now

Welcome to the main community in programming.dev! Feel free to post anything relating to programming here!

Cross posting is strongly encouraged in the instance. If you feel your post or another person's post makes sense in another community cross post into it.

Hope you enjoy the instance!

Rules

Rules

  • Follow the programming.dev instance rules
  • Keep content related to programming in some way
  • If you're posting long videos try to add in some form of tldr for those who don't want to watch videos

Wormhole

Follow the wormhole through a path of communities !webdev@programming.dev



founded 1 year ago
MODERATORS
 

I recently hired into a data analytics team for a hospital, and we don't have a style guide. Lots of frustration from folks working with legacy code...I thought putting together a style guide would help folks working with code they didn't write, starting with requiring a header for SQL scripts first as low hanging fruit.

Or so I thought.

My counterpart over application development says that we shouldnt be documenting any metadata in-line, and he'd rather implement "docfx" if we want to improve code metadata and documentation. I'm terrified of half-implementing yet another application to further muddy the waters--i'm concerned it will become just one-more place to look while troubleshooting something.

Am I going crazy? I thought code headers were an industry standard, and in-line comments are regarded as practically necessary when working with a larger team...

you are viewing a single comment's thread
view the rest of the comments
[–] RustySharp@programming.dev 7 points 1 year ago (4 children)

...what the code does, not why it does it

This is my issue with "it's self documenting code!". I'm a maintenance coder. I deal with people's code long after they're dead (or ragequit). Some are for control systems.

if (waterPressure_psi > 500) raise PipeMayBurstException. Okay, we're dealing with water pressure, in psi unit, and if it's too high, it may break the piping. Self documenting!!

Except that our pipes are rated for 1000psi. SO WHY THE 500?! Do we have one or two sites - out of hundreds - with lower rated pipes? I can double performance if we raise the threshold to 700, well within the safety tolerance, but AM I GONNA KILL SOMEONE when they upgrade to our latest controller??

[–] glue_snorter@lemmy.sdfeu.org 2 points 1 year ago* (last edited 1 year ago) (2 children)

Ugh, a Magic String (I call it that whatever the type)

FACILITY_MAX_PRESSURES = {
    "Durham": 1000,
    "Ipswich": 500,
    "Calne": 750,
}

max_pressure = list(sorted(
    FACILITY_MAX_PRESSURES.values()
))[-1]

if water_pressure > max_pressure:
    blah

Obviously it should really pull from facility management, but that's a bunch of moving parts where a constant is how you'd prefer the code to work

Tbh it starts to look better to just define a constant and comment it.

[–] RustySharp@programming.dev 4 points 1 year ago* (last edited 1 year ago) (1 children)

Tbh it starts to look better to just define a constant and comment it.

Well.. if (waterPressure > MAX_PRESSURE_BEFORE_YOU_FLOOD_THE_WHOLE_TOWN_OF_IPSWICH_AND_CALNE) is pretty self-documenting. No comments needed.

[–] drdnl@programming.dev 3 points 1 year ago

Although a bit long, I do like this almost impossible to ignore example of self documenting code :)

load more comments (1 replies)